Repairing a broken USB port in a Wacom Intuos 4 L

Wacom Intuos 4 L tablets are notorious for having their USB ports just soldered on top of the PCB and breaking off at the slightest push. Whoever at Wacom thought flat mounting of an element that’s inevitably going to be subject to stress is a good idea should be fired, and then fired upon. When users complained, Wacom support had the audacity to claim the socket must’ve been broken by excessive force, and they can only replace the Intuos 4 L board with a new one, at the price of almost a new unit, and of course the new PCB is going to have the same design flaw as the old one, so it’ll break sooner or later anyway.

(Blatant keywording notice. This post is intentionally chock full of direct references to Wacom, Intuos 4 L, and broken USB ports. Hopefully it’ll be useful to people with the same problem.)

No way, Wacom. Let’s fix this baby.

Continue reading “Repairing a broken USB port in a Wacom Intuos 4 L”

Why WoW Graphics Suck (or how easily they could be improved)

Everyone knows WoW has graphics dating back to 2004. Sure, new graphics are added, and many new weapons, armour and areas have received the high-poly and high-res-texture treatment… But not the old characters, no, no.

Blizzard claims they’re not planning on increasing the polycount on characters, as that would strain older computers too much (but they’re happy adding polys to weapons and armor, largely replacing much of the low-poly characters, so that logic fails here). However, would they really need to increase the POLYCOUNT, of all things?

How about some normal maps, hello?

Continue reading “Why WoW Graphics Suck (or how easily they could be improved)”

Emacsem przez Sendmail, czy raczej Qmailem na Gmaila

Gmail mnie nie lubi. Uwziął się, że maile z mojego IP (jakiekolwiek teraz w Netii bym nie dostał) będzie traktował jako spam, i już z SMTPa mnie odsyła precz. No to, pomyślałem, ja cię załatwię, draniu. Wpisałem sobie w /var/qmail/control/smtproutes:
:smtp.gmail.com
Ale nie, figa, to samo. Na jakiejś przydatnej stronce przeczytałem, że to trzeba w pełni poprawnie, przez TLS, z hasłem i w ogóle. Ale tu niespodzianka – goły qmail, z pakietu netqmail-1.05, nie zna sztuczek ze STARTTLS ani podobnych, ba, nie ma nawet łatki “remote-auth”, pozwalającej mu podawać poświadczenia przy przesyłaniu poczty gdzieś dalej! No ale nic to, walczymy. Instaluję netqmail-1.06, łatam netqmail-1.05-tls-smtpauth-20070417.patch, aby nauczyć qmaila TLSa i SMTP-AUTH (poszło pięknie), łatam qmail-remote-auth.patch, aby qmail-remote umiał logować się jak zwykły MUA… I co? I dupa! Patch był do starszego qmaila, albo na innym poziomie patchowania, cokolwiek. Nie pasuje i już.

Cóż było robić… napisałem własnego patcha. Bierzcie i jedzcie z tego wszyscy. Oto mój patch.

Oczywiście jeszcze o /var/qmail/control/smtproutes było trzeba zadbać:
:smtp.gmail.com:587 user@gmail.com password

I teraz działa.

 Here’s the long story cut short: If you’re trying to get qmail to have both TLS, SMTP-AUTH and remote-auth capabilities, just install netqmail-1.06, patch it with the netqmail-1.05-tls-smtpauth-20070417.patch, and then apply my patch instead of the vanilla qmail-remote-auth.patch which doesn’t work with a tls-smtpauth patch under it. Done.

No to mamy 4 mbit :]

Netia sfailowała z wyborem firmy kurierskiej. Wręczyli mój router-AP firmie DPD. Kurier w czwartek (7.08) chciał się umówić na odbiór, ale jeszcze byłem poza Warszawą. Jeszcze zadzwonił w poniedziałek, ale nie zdążyłem odebrać komórki – trzy dzwonki, tak na oko, i dzwoniący się rozłączył, a dzwonił z zastrzeżonego, więc nie mogłem oddzwonić. Dziś się zaś dowiaduję, że firma kurierska już zwróciła przesyłkę nadawcy jako niedostarczoną! Nie minęło jeszcze “przepisowych” 7 dni, i kurier tylko raz tak naprawdę szczerze próbował się umówić na odbiór… Musiałem Netię pogonić, żeby znowu wysłali ustrojstwo, i to już nie firmą DPD, ale to zajmie jeszcze ze 2-3 dni.

Tymczasem – Polak nie cielę, sobie poradzi. Stary neostradowy modem Sagem F@st 800 bardzo ładnie Netię też obsługuje, także sieć już mam. Śliczne 4 mbit / 500 kbit. I to taniej, niż 1 mbit / 256 kbit w neozdradzie ;P

Pielgrzymka z neostrady do netii

Przenoszę się właśnie z neostrady tepsowej na netiowy 4mbit – lecz oto znalazłem się w kuriozalnym punkcie.

1 sierpnia wygasła mi umowa z TPSA na neostradę. Sieć padła szybciutko, livebox się nie łączy, prawidłowo. Tegoż samego dnia, wedle umowy, moje łącze miała przejąć Netia – na mocy jakiejś umowy między operatorami o uwolnienie czegoś tam – nie wiem, pewnie i przejęła.

12 sierpnia mieli mi włączyć usługę sieciową, mój wymarzony 4mbit – ale kurier się spóźnia, na dodatek jeszcze ja zgubiłem dowód i mogą być jaja z legitymowaniem się… Dzwonię zatem na netiową infolinię i potwierdzam, że od biedy można z ich internetu korzystać nawet starym Sagemem od neostrady, bo to też ADSL i nawet na tych samych co neo parametrach.

Sagema nie zmusiłem do pracy, no to odpakowałem już zapakowanego do zwrotu liveboxa.

I tu – niespodzianka. Livebox się zsynchronizował… ZALOGOWAŁ na moje dane neostradowe… i dostałem stary adres IP z puli neostrady!

Czyli – mam cały czas neostradę, choć łącze już jest pod kontrolą Netii i z TPSA nie wiąże mnie już zupełnie nic. Hm, to może ja ten internet netiowy zawieszę i będę miał neo za darmo, skoro TPSA o mnie zapomniała? Albo co?

Ale jajo, co? 😀